Страница
5

Автоматизация учета расчетов с поставщиками и подрядчиками

Отредактируем журнал ПриходныеНакладные. Добавим в него две графы – Кол из реквизита таблицы Кол, и Сумма из реквизита Сумма. Настроим форму журнала.

Перейдем к форме документа. Создаем ее.

В поле Наименование пишем формулу Товар(), в поле Цена – Цена (). Под таблицей добавим текст с формулой для вычисления суммы по колонке Итог("Кол"), Итог("Сумма"). Page generation 0.010 seconds

В модуле формы документа пишем:

Процедура ПриОткрытии()

ПриЗаписиПерепроводить(1);

КонецПроцедуры

Процедура Наименование()

Если Наименование.Выбран()=1 Тогда

КонецЕсли;

КонецПроцедуры

Процедура Цена()

Цена=Окр(Наименование.Цена);

Сумма=Окр(Кол*Цена,2,1);

КонецПроцедуры

Процедура Печать()

Таб=СоздатьОбъект("Таблица");

Таб.ИсходнаяТаблица("Таблица");

Таб.ВывестиСекцию("Шапка");

ВыбратьСтроки();

Пока ПолучитьСтроку()=1 Цикл

НС=НомерСтроки;

// атрибут НомерСтроки возвращает номер текущей строки

// табличной части

Таб.ВывестиСекцию("Строка");

КонецЦикла;

ИтогПр=Формат(Итог("Сумма"),"ЧПДС");

// В переменную ИтогПр мы выведем сумму прописью

Таб.ВывестиСекцию("Подвал");

Таб.ТолькоПросмотр(1);

Таб.ПараметрыСтраницы(1,100,1);

Таб.Показать("");

КонецПроцедуры

Рис.22

Создаем печатную форму документа:

Рис.23

Теперь переходим к модулю документа. Пишем процедуру:

Процедура ОбработкаПроведения()

ВыбратьСтроки();

Пока ПолучитьСтроку() = 1 Цикл

Операция.НоваяПроводка();

Операция.Дебет.Счет = СчетПоКоду("10",ПланыСчетов.Наш);

Операция.Дебет.МестоХранения = Склад;

Операция.Дебет.ТоварУслуга = Наименование;

Операция.Дебет.ПриходнаяНакладная = ТекущийДокумент();

Операция.Кредит.Счет = СчетПоКоду("60.0",ПланыСчетов.Наш);

Операция.Кредит.Поставщики = Поставщик;

Операция.Кредит.ПриходнаяНакладная = ТекущийДокумент();

Операция.Кредит.МОЛ = ЧерезТов;

Операция.Сумма = Сумма;

КонецЦикла;

Операция.Содержание = "Поступили материалы от поставщиков";

Операция.СуммаОперации = Итог("Сумма");

Операция.Автор = АвторДокумента;

Операция.Записать();

КонецПроцедуры

Создадим документ в 1С:

Рис.24

Проведем накладную, документ отражается в журнале:

Рис.25

Документ Акт выполненных работ

Данный документ составляется при расчетах с подрядчиками, после завершения работы по договору подряда.

Данный документ составляется по такому же принципу как и предыдуший.

Рис.26

1. Создаем форму документа

2. в модуле формы пишем формулу:

Процедура ПриОткрытии()

ПриЗаписиПерепроводить(1);

КонецПроцедуры

Процедура ОбрВыпРаб()

КонецПроцедуры

Процедура Печать()

Таб=СоздатьОбъект("Таблица");

Таб.ИсходнаяТаблица("Таблица");

Таб.ВывестиСекцию("Шапка");

ВыбратьСтроки();

Пока ПолучитьСтроку()=1 Цикл

НС=НомерСтроки;

// атрибут НомерСтроки возвращает номер текущей строки

// табличной части

Таб.ВывестиСекцию("Строка");

КонецЦикла;

// В переменную ИтогПр мы выведем сумму прописью

Таб.ВывестиСекцию("Подвал");

Таб.ТолькоПросмотр(1);

Таб.ПараметрыСтраницы(1,100,1);

Таб.Показать("");

КонецПроцедуры

4.Составляем печатную форму документа:

Рис.27

5.Создадим документ В 1С:

Рис.28

Данный документ при проведении отражается в журнале "АктВыпРаб".

Документ Договор

На основании договоров производятся поставки ТМЦ и выполняются работы. Создадим два договора: "Договор поставки" и "Договор подряда".

Процесс создания рассмотрим на примере договора поставки.

1. В дереве метаданных в разделе "Документ" добавляем новый документ.

2. В окно редактирования вносим соответствующие значения.

3. Составляем форму документа.

4. В модуле формы пишем процедуру:

Процедура ПриОткрытии()

ПриЗаписиПерепроводить(1);

КонецПроцедуры

Процедура Печать()

Таб=СоздатьОбъект("Таблица");

Таб.ИсходнаяТаблица("Таблица");

Таб.ВывестиСекцию("Шапка");

ВыбратьСтроки();

Пока ПолучитьСтроку()=1 Цикл

НС=НомерСтроки;

// атрибут НомерСтроки возвращает номер текущей строки

// табличной части

Таб.ВывестиСекцию("Строка");

КонецЦикла;

// В переменную ИтогПр мы выведем сумму прописью

Таб.ВывестиСекцию("Подвал");

Таб.ТолькоПросмотр(1);

Таб.ПараметрыСтраницы(1,100,1);

Таб.Показать("");

КонецПроцедуры

Рис.29

5. Создаем печатную форму договора.

6. В 1С заполняем форму договора, проводим его в журнале "Договора", смотрим печатную форму:

Рис.30

Документ Доверенность

Данный документ создается при получении товароматериальных ценностей, является оправдательным документом при передаче ТМЦ.

1. Создаем документ

2. Заполняем в окне редактирования необходимые данные

3. Создаем форму документа

4. В модуле формы пишем процедуру:

Процедура ПриОткрытии()

ПриЗаписиПерепроводить(1);

КонецПроцедуры

Процедура Печать()

Таб=СоздатьОбъект("Таблица");

Таб.ИсходнаяТаблица("Таблица");

Таб.ВывестиСекцию("Шапка");

ВыбратьСтроки();

Пока ПолучитьСтроку()=1 Цикл

НС=НомерСтроки;

// атрибут НомерСтроки возвращает номер текущей строки

// табличной части

Таб.ВывестиСекцию("Строка");

КонецЦикла;

// В переменную ИтогПр мы выведем сумму прописью

Таб.ВывестиСекцию("Подвал");

Таб.ТолькоПросмотр(1);

Таб.ПараметрыСтраницы(1,100,1);

Таб.Показать("");

КонецПроцедуры

5. Создаем печатную форму документа:

Рис.31

6.Создадим доверенность в 1С. Проведем документ. Он находит свое отражение в журнале по учету доверенностей "Доверенность"

Рис.32

Рис.33

2.5 Создание отчетов

Отчет является документом, который обобщает, формирует, анализирует данные за весь отчетный период.

Перейти на страницу номер:
 1  2  3  4  5  6